Practical 1: Introduction to ArcMap

Part 1
The aim of Part 1 of this exercise is for you to get an understanding of the way spatial data is organised in ArcMap and to explore some basic GIS procedures. By the end of this practical you should be able to:

- Open an existing ArcMap map project.
- Navigate and organise layers of data.
- Query layer features.
- Select features from a layer based on attribute.
- Perform simple locational and attribute queries.

You should copy all of the folder Prac1 to your file space and work from that, setting write permissions on the folder and files as you need.

1. Start ArcMap
Launch ArcMap by selecting Start > ArcGIS > ArcMap

When the ArcMap start dialog appears click ‘A new empty map’ and then click OK. This is the main ArcMap interface. Maximise this window to fill the screen by clicking the square at the top right of the window. ArcMap saves your work in a map document or project that has an .mxd extension.

2. Working with layers
Spatial data is organised in a series of layers that creates a map. A map project (.mxd file) has been created for this exercise. You will use this document to see how data is organised in ArcMap.

On the main menu bar select File > Open.

Navigate to the Practical folder location and double click Niigata.mxd to open the file.

In this file opens you will see a set of layers of an area around Niigata.
Notice how different features are organised into layers in the Table of Contents on the left hand side of the screen.

Questions:
- How many layers are currently available in the Table of Contents?
- How many are actually visible in the display area?
- The roads are represented as what type of feature: points, lines or polygons?

Click on the tick box next to the Niigata Natural Areas layer in the Table of Contents. The map is redrawn showing the areas representing inland water and woodland.

Layers may be reordered and renamed in the Table of Contents. At the bottom of the Table of Contents are three tabs. The Sources tab shows the location of the original data. The Display tab shows how map layers are ordered when drawing the map. The Selection tab shows a list of the layers in the active data frame and lets you check the ones you want to make selectable.

Select the Display tab. Click on the Niigata Census 2005 layer and drag it up the table of contents until it is above the Roads layer. The map will be redrawn with the census areas obscuring the layers below. Now drag the Niigata Census layer back to its original location in the Table of Contents and turn the layer visibility off.

Layers may be renamed using two methods. In the Table of Contents right click on the Niigata Census layer name. A context menu opens. You can use this menu to access many operations.

On the context menu click Properties to open the Layer Properties dialog. There are several tabs relating to different properties of the layer and how the layer is displayed. Click the General tab. Highlight the Layer Name (Urban) and change it to Demographic. Click OK.

The layer is renamed in the Table of Contents.
Another way to change a layer name is simply to click on it gently twice in the Table of Contents and edit it directly.
3. Changing scale of view
The Tools toolbar contains operations for navigating, selecting and querying features on a map.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in</td>
<td></td>
</tr>
<tr>
<td>Fixed zoom in</td>
<td></td>
</tr>
<tr>
<td>Pan</td>
<td></td>
</tr>
<tr>
<td>Previous extent</td>
<td></td>
</tr>
<tr>
<td>Select Features</td>
<td></td>
</tr>
<tr>
<td>Select Elements</td>
<td></td>
</tr>
<tr>
<td>Find</td>
<td></td>
</tr>
<tr>
<td>Measure</td>
<td></td>
</tr>
<tr>
<td>HTML Popup</td>
<td></td>
</tr>
<tr>
<td>Zoom out</td>
<td></td>
</tr>
<tr>
<td>Fixed zoom out</td>
<td></td>
</tr>
<tr>
<td>Full extent</td>
<td></td>
</tr>
<tr>
<td>Next extent</td>
<td></td>
</tr>
<tr>
<td>Clear Selected Features</td>
<td></td>
</tr>
<tr>
<td>Identify</td>
<td></td>
</tr>
<tr>
<td>Go to X Y</td>
<td></td>
</tr>
<tr>
<td>Hyperlink</td>
<td></td>
</tr>
<tr>
<td>Create Viewer Window</td>
<td></td>
</tr>
</tbody>
</table>

Use the zoom in tool to zoom in several times. The scale of the view is shown on the map interface on the standard toolbar. This can be done using the mouse wheel.

Questions:
- What do you notice about the Points Of Interest features on the map?
- At what scale do they appear?

Labels and map layers can be set to appear within a given scale range or above or below a given threshold. This is called scale dependent display.

Click on the Full extent button on the tools menu. The map should now be shown in full.
- What scale is the full extent of the map?

Now type 50,000 in the scale box on the standard tool bar and click <RETURN>. The view zooms to the centre of the map of Niigata.

Use the pan tool to drag the map such that the Petrol station in the top left appears at the centre of the map.
- What Points of Interest features are there around this Petrol station?

If you have a particular section of a map that you need to refer to often this can be set as a bookmark. Select View ➔ Bookmark ➔ Create. Type Niigata Suburb into the dialogue box and click on OK. Now zoom to full extent of the map (use the Globe symbol).
To go back to your bookmark select View ➔ Bookmark ➔ Niigata Suburb and the view will return to your saved extent.
4. Measurements
It is often useful to get a rough measure of distance between features without doing more complex analyses.

Make sure the Niigata Natural Areas layer is displayed. Zoom to the North West part of the map, such that the Airport and the Lake in the centre of the map are displayed. Click on the Measure tool. Place the cursor on the Airport and click. Move the cursor to the lake and double click. The measured distance will be shown in the window that pops up with this tool.

- How far is it from the Airport to the lake?

You can measure a series of attached line segments by clicking once at the end of each segment and twice at the end of the complete line measure.

5. Attribute information associated with a vector layer
If you are creating interactive maps for use on screen then there are two ways of finding or displaying attributes for individual features on the map: map tips and identify.

Attributes of individual features on a map can be queried using the Identify tool found on the Tools toolbar. With the Niigata Natural Areas layer displayed, click on the Identify icon. Now clink on the Lake.

- What information is contained in the Comment attribute of this feature?

Use the Identify tool to look at attributes of other features on the map. You can look at any layer by selecting its name from the drop down menu at the top of the Identify Results dialogue.

Information (as contained in the attribute table) can also be displayed as Map Tips that are shown by ‘brushing’ over features on the map. Open the Properties dialogue for Niigata Natural Areas layer. Click on the Display tab and check the box next to Show Map Tips. Click on the Fields tab and set Comment as the primary display field. Click OK.
Now if you move the cursor over (brush) any features in this layer the Comment attribute of the feature will be displayed as a Map Tip (note in this instance on there are forest areas and 2 lakes). Now open Properties and turn off the Map Tips.

The complete attributes for any layer can be displayed by opening the Attribute Table for that layer. Right click on the Points of Interest layer. Click Open Attribute Table.

The attribute table contains records that represent individual features in the layer. The bottom section of the table provides summary information on the records in the table.

- How many records are there in Points of Interest attribute table?

Scroll across the table to view the attributes for each record.

- What Category of feature is ‘Information Source’?

Close the attribute table.

Now open the attribute table for the roads layer.

- How many records are in this table?
- What is the length of the longest road segment? Hint: open the attribute table, right click on the ‘Length’ attribute and select Sort Descending – the highest value will be at the top of the table.

Close the road attribute table.

Highlight this record in the attribute table and then right click and select ‘Zoom to’. The map centres on this feature which is highlighted.

Return to the Full Extent of the map and deselect the selected features (Selection > Clear selected features)

6. Selecting features from a vector layer

In the last part of Section 5 above, you selected after manually and examined it.

In geographical analysis it is often useful to formally select features that fulfil certain criteria. In order to do this, you need to interrogate a layer’s attribute table. On the main menu bar (at the top of the window) click Selection > Select by Attributes.

This dialogue box allows you to construct queries for the layers in your map. You will use the Roads layer and formulate an expression to select only those road segments that have a length greater than 2500. The selected roads will then be highlighted on the map.

Select Roads in the Layer drop down list. In the Fields box double click on Length to select it – this should appear in the SQL expression box. Click once on the > symbol from the list of operations. Now type 2500 in the expression box so that the query appears as: "Length" > 2500

Click Apply.

In the map window the road segments with length over 2500 will be highlighted in blue. The number of items selected will be shown in the bottom left hand corner of the ArcMap window.

Right click on the Roads layer and then Selection > Create layer from selected features

Examine the attribute table of the Roads selection layer
Part 2
The aim of Part 2 of this exercise is for you understand the different ways that spatial data are represented. By the end of this practical you should be able to:
- Understand the differences between Raster and Vector representations
- Use basic tools and associated with the different data types;
- Create and export raster and vector layers

1. Raster creation
In Part 1 of this practical, you exclusively used vector data that represented features as discrete objects as lines, points and areas. Raster data represents features as continuous field of values.

Using the same project file as Part 1 (Niigata.mxd), in this part of the exercise you will create and compare two population maps in different formats. First you need to make a copy of the census data. This will used to create raster layer from the centroids of each census area polygon (the centroid is the geometric centre of each polygon). The population will be used to provide the continuous variable.

Right click on the Niigata Census 2005 layer
Data > Export Data and call the result Census_copy and add the exported file to your project
Open the attribute table of Census_copy layer

Click on Options and Add Field and name the new attribute X. Do the same for another new file and this time name it Y.

Right click on the X field and select Calculate Geometry, and select X Coordinate of Centroid as below. Do the same for Y, selecting Y Coordinate of Centroid.
Now export the attribute table of Census_copy. Open its attribute table and select **Options > Export**

In the ensuing dialogue box, click on the folder tab to get the window below, navigate to your preferred file location (e.g. your work folder) and select **Text file** in ‘Save as type:’ Name the file **censuspoint.csv**, click on **Save** and then **OK**

Then click on the Add Data button navigate to the location you chose and select your csv file.
The Table of contents will switch to Source and the CSV file will be displayed. Check the data it has (Right click > Open). You should have the table as below.

Now you will create a point dataset. Right click on the CSV file and select **Display XY data. In the ensuing dialogue window**, make X and Y are in the X field and Y field respectively and click OK. Ignore the warning message. You should have the map below.
This data can be converted to a Raster using the conversion tools in the Toolbox.

In ArcToolbox, navigate to

**Spatial Analyst > Interpolation > IDW**

And complete the tool as below. Click OK.

![IDW Tool Image](image)

Double click on the layer that is created and set the items in the Symbology tab as below.

![Symbology Settings Image](image)
You will notice that this layer has interpolated values for all points in the XY bounding box.

Add the raster named ‘Mask’ to mask out these unwanted areas. The resulting map should look similar to the below.

2. Raster examination

You should now spend some time exploring this dataset raster and think about how this data compares
   1) to the format of the other data you have manipulated in this exercise
   2) to the Niigata Census 2005 layer.
To do this you can examine the table of contents, try selecting some features, use the identify tool, In the Properties > Symbology change the number of classes and the colour.

To help with the comparison and your evaluation of the different formats, you should display the Niigata Census 2005 layer as below (Properties > Symbology)
After examining the data and thinking about your understanding of these features you should be able to write a few words in answer to the question below (not the answers to these questions are not in the answer sheet).

- What are the main difference between a vector and raster table of contents?
- What are the main difference between a vector and raster representation?
- What do you think the advantages / disadvantages are of the different ways of representing geographic features?

3. Using ArcMap Desktop help

It is useful for you to know how to use help as you may come across new procedures, or know what you want to do but not necessarily know how to do it!

Select Help > ArcMap Desktop Help from the main menu bar. Click on the Contents tab. Sometimes you may know key words for a function that you wish to use. Click on the Index tab and type layers. You are given a list of all the associated functions. Click on ‘adding to maps’ and in the new dialog double click on Adding layers to a map.

Using the Search tab you can type in search phrases to try to identify specific procedures. Any pages that you might want to refer to again can be saved under Favourites.

One task you should try is to export data to Google Earth. It may be that you have some data that you have collected – for example with a GPS and you want to visualise this quickly and easily, either to check it yourself or to share with colleagues. You should try to generate a KML file from the Points of Interest layer.
In the help menu under the **Index** tab search for KML (this is the file format for Google Earth). You should find something like the below.

Under creating KML files, you should find reference to the **Layer to KML** tool. Now back in ArcMAP find this tool in ArcToolbox – click on icon to access the tool box. The under the Index tab, type ‘Layer to KML’ and you should find two options, pick the ‘conversion’ option. Specify the Points of Interest Layer, a name and location for the output and a scale of 10,000.

When you have created the layer you can look at the KML layer in Google Earth if you have it installed.

Quit ArcMap saving any changes if you wish to.

**End of Practical 1**